This package browser is in early development. Mind the rough edges.

perl-any-moose 0.27

Transparently use Moose or Mouse modules

This module facilitates using Moose or Mouse modules without changing the code. By default, Mouse will be provided to libraries, unless Moose is already loaded, or explicitly requested by the end-user. End users can force the decision of which backend to use by setting the environment variable ANY_MOOSE to be Moose or Mouse.

Installation

Install perl-any-moose 0.27 as follows:

guix install perl-any-moose@0.27

Or install the latest version:

guix install perl-any-moose

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.