perl-data-visitor 0.30
Visitor style traversal of Perl data structures
This module is a simple visitor implementation for Perl values. It has a main dispatcher method, visit, which takes a single perl value and then calls the methods appropriate for that value. It can recursively map (cloning as necessary) or just traverse most structures, with support for per-object behavior, circular structures, visiting tied structures, and all ref types (hashes, arrays, scalars, code, globs).
- Website: https://metacpan.org/release/Data-Visitor
- Licenses: GPL 1+
- Package source: gnu/packages/perl.scm
- Builds: See build status
- Issues: See known issues
Installation
Install perl-data-visitor 0.30
as follows:
guix install perl-data-visitor@0.30
Or install the latest version:
guix install perl-data-visitor
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.