This package browser is in early development. Mind the rough edges.

perl-module-build-xsutil 0.16

Module::Build class for building XS modules

Module::Build::XSUtil is subclass of Module::Build for support building XS modules.

This is a list of a new parameters in the Module::Build::new method:

  1. needs_compiler_c99: This option checks C99 compiler availability.

  2. needs_compiler_cpp: This option checks C++ compiler availability. Can also pass extra_compiler_flags and extra_linker_flags for C++.

  3. generate_ppport_h: Generate ppport.h by Devel::PPPort.

  4. generate_xshelper_h: Generate xshelper.h which is a helper header file to include EXTERN.h, perl.h, XSUB.h and ppport.h, and defines some portability stuff which are not supported by ppport.h.

    It is ported from Module::Install::XSUtil.

  5. cc_warnings: Toggle compiler warnings. Enabled by default.

  6. -g options: Invoke Build.PL with -g to enable debug options.

Installation

Install perl-module-build-xsutil 0.16 as follows:

guix install perl-module-build-xsutil@0.16

Or install the latest version:

guix install perl-module-build-xsutil

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.