perl-readonly-xs 1.05
Companion module for `Readonly.pm', to speed up read-only scalar variables
The Readonly
module is an effective way to create non-modifiable variables. However, it's relatively slow.
The reason it's slow is that is implements the read-only-ness of variables via tied objects. This mechanism is inherently slow. Perl simply has to do a lot of work under the hood to make tied variables work.
This module corrects the speed problem, at least with respect to scalar variables. When Readonly::XS
is installed, Readonly
uses it to access the internals of scalar variables. Instead of creating a scalar variable object and tying it, Readonly
simply flips the SvREADONLY
bit in the scalar's FLAGS
structure.
- Website: https://metacpan.org/release/Readonly-XS
- Licenses: GPL 1+
- Package source: gnu/packages/perl.scm
- Builds: See build status
- Issues: See known issues
Installation
Install perl-readonly-xs 1.05
as follows:
guix install perl-readonly-xs@1.05
Or install the latest version:
guix install perl-readonly-xs
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.