primesieve
Prime number generator
primesieve
is a command-line program and C/C++ library for quickly generating prime numbers. It is very cache efficient, it detects your CPU's L1 & L2 cache sizes and allocates its main data structures accordingly. It is also multi-threaded by default, it uses all available CPU cores whenever possible i.e. if sequential ordering is not required. primesieve can generate primes and prime k-tuplets up to 264.
- Versions: 12.3
- Website: https://github.com/kimwalisch/primesieve
- Licenses: FreeBSD
- Package source: gnu/packages/maths.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of primesieve
as follows:
guix install primesieve
Or install a particular version:
guix install primesieve@12.3
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/primesieve/'><img src='http://127.0.0.1:3000/packages/primesieve/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/primesieve/badges/latest-version.svg)](http://127.0.0.1:3000/packages/primesieve/) Org: [[http://127.0.0.1:3000/packages/primesieve/][http://127.0.0.1:3000/packages/primesieve/badges/latest-version.svg]]