primesieve 12.3
Prime number generator
primesieve
is a command-line program and C/C++ library for quickly generating prime numbers. It is very cache efficient, it detects your CPU's L1 & L2 cache sizes and allocates its main data structures accordingly. It is also multi-threaded by default, it uses all available CPU cores whenever possible i.e. if sequential ordering is not required. primesieve can generate primes and prime k-tuplets up to 264.
- Website: https://github.com/kimwalisch/primesieve
- Licenses: FreeBSD
- Package source: gnu/packages/maths.scm
- Builds: See build status
- Issues: See known issues
Installation
Install primesieve 12.3
as follows:
guix install primesieve@12.3
Or install the latest version:
guix install primesieve
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.