This package browser is in early development. Mind the rough edges.

python-afdko 3.6.1

Adobe Font Development Kit for OpenType

The Adobe Font Development Kit for OpenType (AFDKO) is a set of tools for building OpenType font (OTF) files from PostScript and TrueType font data. It includes the following commands:

buildcff2vf

Assemble a CFF2 variable font from a .designspace file.

buildmasterotfs

Build master source OpenType/CFF fonts from a .designspace file and UFO master source fonts.

charplot
dtdigiplotdtfontplotdtfontsetplotdthintplotdtwaterfallplot

Aliases for the corresponding options of the proofpdf command.

checkoutlinesufo

Perform outline quality checks. It can also remove path overlaps.

comparefamily

Look in a specific directory, examine and report on all the OpenType fonts found.

type1
dtdetype1

Compile and decompile, respectively, a Type 1 font to and from a plain-text representation.

makeinstancesufo

Generate UFO font instances from a set of master UFO fonts.

makeotfexe

Read all the font data and build the final OpenType font.

makeotf

This command can be used to prepare the input files needed by makeotfexe.

mergefonts

Merge one or more fonts into a parent font.

otc2otf

Extract all OpenType fonts from the parent OpenType Collection font.

otf2otc

Build an OpenType Collection font file from two or more OpenType font files.

otf2ttf

Converts OpenType-CFF fonts to TrueType.

rotatefont

Apply a Postscript transform matrix to the source font files.

sfntdiff

Low-level comparison of two OpenType font files.

sfntedit

Support table-editing, listing, and checksumming options on sfnt-formatted files such as OpenType Format (OTF) or TrueType.

spot

Dump sfnt data from plain files or Macintosh resource files.

ttfcomponentizer

Take in a TrueType font and look for a UFO font stored in the same directory. Use the UFO's components data to compose matching TrueType glyphs.

ttfdecomponentizer

Take in a TrueType font and decompose any composite glyphs into simple glyphs.

ttxn

Make a normalized dump of the font, or of selected tables.

tx

The tx (Type eXchange) is a test harness for the CoreType libraries but also provides many useful font conversion and analysis facilities.

Installation

Install python-afdko 3.6.1 as follows:

guix install python-afdko@3.6.1

Or install the latest version:

guix install python-afdko

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.