python-fire 0.6.0
Library for automatically generating command line interfaces
Fire is a library for automatically generating command line interfaces from absolutely any Python object. The following are the advantages:
A simple way to create a CLI in Python.
A helpful tool for developing and debugging Python code.
Helps with exploring existing code or turning other people's code into a command line interface.
Makes transitioning between Bash and Python easier.
Makes using a Python REPL easier by setting up the REPL with the modules and variables you'll need already imported and created.
- Outputs:
out
- Website: https://github.com/google/python-fire
- Licenses: ASL 2.0
- Package source: gnu/packages/python-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install python-fire 0.6.0
as follows:
guix install python-fire@0.6.0
Or install the latest version:
guix install python-fire
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.