python-fitsio
Python library to read from and write to FITS files
This package provides a Python library for reading from and writing to FITS files using the CFITSIO library. Among other things, it can
read and write image, binary, and ascii table extensions;
read arbitrary subsets of tables in a lazy manner;
query the rows and columns of a table;
read and write header keywords;
read and write Gzip files.
- Versions: 1.2.0
- Website: https://github.com/esheldon/fitsio
- Licenses: GPL 2+
- Package source: gnu/packages/astronomy.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-fitsio
as follows:
guix install python-fitsio
Or install a particular version:
guix install python-fitsio@1.2.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.