python-fs
File system abstraction layer for Python
PyFilesystem's FS
object is a file system abstraction sharing similarities with Python's own file
object for single files. It allows opening all the files under a given directory recursively, as a single FS
object. This enables, for example, counting the combined number of lines in the contained files easily.
- Versions: 2.4.16
- Website: https://github.com/PyFilesystem/pyfilesystem2/
- Licenses: Expat
- Package source: gnu/packages/python-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-fs
as follows:
guix install python-fs
Or install a particular version:
guix install python-fs@2.4.16
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.