This package browser is in early development. Mind the rough edges.

python-grandalf 0.7

Graph and drawing algorithms framework

Grandalf is a Python package made for experimentations with graphs drawing algorithms. It is written in pure Python, and currently implements two layouts: the Sugiyama hierarchical layout and the force-driven or energy minimization approach. While not as fast or featured as graphviz or other libraries like OGDF (C++), it provides a way to walk and draw graphs no larger than thousands of nodes, while keeping the source code simple enough to tweak and hack any part of it for experimental purpose. With a total of about 1500 lines of Python, the code involved in drawing the Sugiyama (dot) layout fits in less than 600 lines. The energy minimization approach is comprised of only 250 lines!

Grandalf does only 2 not-so-simple things:

  • computing the nodes (x,y) coordinates (based on provided nodes dimensions, and a chosen layout)

  • routing the edges with lines or nurbs

It doesn’t depend on any GTK/Qt/whatever graphics toolkit. This means that it will help you find where to draw things like nodes and edges, but it’s up to you to actually draw things with your favorite toolkit.

Installation

Install python-grandalf 0.7 as follows:

guix install python-grandalf@0.7

Or install the latest version:

guix install python-grandalf

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.