python-pandera 0.18.0
Perform data validation on dataframe-like objects
python-pandera
provides a flexible and expressive API for performing data validation on dataframe-like objects to make data processing pipelines more readable and robust. Dataframes contain information that python-pandera
explicitly validates at runtime. This is useful in production-critical data pipelines or reproducible research settings. With python-pandera
, you can:
Define a schema once and use it to validate different dataframe types.
Check the types and properties of columns.
Perform more complex statistical validation like hypothesis testing.
Seamlessly integrate with existing data pipelines via function decorators.
Define dataframe models with the class-based API with pydantic-style syntax.
Synthesize data from schema objects for property-based testing.
Lazily validate dataframes so that all validation rules are executed.
Integrate with a rich ecosystem of tools like
python-pydantic
,python-fastapi
andpython-mypy
.
- Outputs:
out
- Website: https://github.com/unionai-oss/pandera
- Licenses: Expat
- Package source: gnu/packages/python-science.scm
- Builds: See build status
- Issues: See known issues
Installation
Install python-pandera 0.18.0
as follows:
guix install python-pandera@0.18.0
Or install the latest version:
guix install python-pandera
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.