python-pybcj 1.0.1
BCJ filter library
In data compression, BCJ, short for Branch-Call-Jump, refers to a technique that improves the compression of machine code of executable binaries by replacing relative branch addresses with absolute ones. This allows a LZMA compressor to identify duplicate targets and archive higher compression rate. BCJ is used in the 7-zip compression utility as the default filter for executable binaries.
pybcj provides Python bindings to a BCJ implementation in C.
- Website: https://codeberg.org/miurahr/pybcj
- Licenses: LGPL 2.1+
- Package source: gnu/packages/python-compression.scm
- Builds: See build status
- Issues: See known issues
Installation
Install python-pybcj 1.0.1
as follows:
guix install python-pybcj@1.0.1
Or install the latest version:
guix install python-pybcj
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.