This package browser is in early development. Mind the rough edges.

python-pyfakefs

Mock file system interactions in tests

This package provides a Python library intended for use in automated tests. One difficulty when testing software is that the code under test might need to read or write to files in the local file system. If the file system is not set up in just the right way, it might cause a spurious error during the test. The pyfakefs library provides a solution to problems like this by mocking file system interactions. In other words, it arranges for the code under test to interact with a fake file system instead of the real file system. The code under test requires no modification to work with pyfakefs.

Installation

Install the latest version of python-pyfakefs as follows:

guix install python-pyfakefs

Or install a particular version:

guix install python-pyfakefs@4.6.3

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.