This package browser is in early development. Mind the rough edges.

python-pytorch 2.0.1

Python library for tensor computation and deep neural networks

PyTorch is a Python package that provides two high-level features:

  • tensor computation (like NumPy) with strong GPU acceleration;

  • deep neural networks (DNNs) built on a tape-based autograd system.

You can reuse Python packages such as NumPy, SciPy, and Cython to extend PyTorch when needed.

Note: currently this package does not provide GPU support.

Installation

Install python-pytorch 2.0.1 as follows:

guix install python-pytorch@2.0.1

Or install the latest version:

guix install python-pytorch

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.