python-websockets
Python implementation of the WebSocket Protocol (RFC 6455 & 7692)
websockets
is a library for building WebSocket servers and clients in Python with a focus on correctness and simplicity.
Built on top of asyncio
, Python's standard asynchronous I/O framework, it provides an elegant coroutine-based API.
- Versions: 13.0
- Website: https://github.com/aaugustin/websockets
- Licenses: Modified BSD
- Package source: gnu/packages/python-web.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of python-websockets
as follows:
guix install python-websockets
Or install a particular version:
guix install python-websockets@13.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/python-websockets/'><img src='http://127.0.0.1:3000/packages/python-websockets/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/python-websockets/badges/latest-version.svg)](http://127.0.0.1:3000/packages/python-websockets/) Org: [[http://127.0.0.1:3000/packages/python-websockets/][http://127.0.0.1:3000/packages/python-websockets/badges/latest-version.svg]]