python-websockets 13.0
Python implementation of the WebSocket Protocol (RFC 6455 & 7692)
websockets
is a library for building WebSocket servers and clients in Python with a focus on correctness and simplicity.
Built on top of asyncio
, Python's standard asynchronous I/O framework, it provides an elegant coroutine-based API.
- Website: https://github.com/aaugustin/websockets
- Licenses: Modified BSD
- Package source: gnu/packages/python-web.scm
- Builds: See build status
- Issues: See known issues
Installation
Install python-websockets 13.0
as follows:
guix install python-websockets@13.0
Or install the latest version:
guix install python-websockets
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.