This package browser is in early development. Mind the rough edges.

quazip

Qt/C++ wrapper for Minizip

QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that can be used to access ZIP archives. It uses Trolltech's Qt toolkit.

QuaZIP allows you to access files inside ZIP archives using QIODevice API, and that means that you can also use QTextStream, QDataStream or whatever you would like to use on your zipped files.

QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both reading from and writing to ZIP archives.

Installation

Install the latest version of quazip as follows:

guix install quazip

Or install a particular version:

guix install quazip@0.9.1

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.