This package browser is in early development. Mind the rough edges.

r-fastmap 1.2.0

Fast implementation of a key-value store

This package provides a fast implementation of a key-value store. Environments are commonly used as key-value stores, but every time a new key is used, it is added to R's global symbol table, causing a small amount of memory leakage. This can be problematic in cases where many different keys are used. Fastmap avoids this memory leak issue by implementing the map using data structures in C++.

Installation

Install r-fastmap 1.2.0 as follows:

guix install r-fastmap@1.2.0

Or install the latest version:

guix install r-fastmap

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.