r-foreach 1.5.2
Foreach looping construct for R
This package provides support for the foreach
looping construct. foreach
is an idiom that allows for iterating over elements in a collection, without the use of an explicit loop counter. This package in particular is intended to be used for its return value, rather than for its side effects. In that sense, it is similar to the standard lapply
function, but doesn't require the evaluation of a function. Using foreach
without side effects also facilitates executing the loop in parallel.
- Outputs:
out
- Website: https://cran.r-project.org/web/packages/foreach
- Licenses: ASL 2.0
- Package source: gnu/packages/cran.scm
- Builds: See build status
- Issues: See known issues
Installation
Install r-foreach 1.5.2
as follows:
guix install r-foreach@1.5.2
Or install the latest version:
guix install r-foreach
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.