This package browser is in early development. Mind the rough edges.

r-promises

Abstractions for promise-based asynchronous programming

This package provides fundamental abstractions for doing asynchronous programming in R using promises. Asynchronous programming is useful for allowing a single R process to orchestrate multiple tasks in the background while also attending to something else. Semantics are similar to JavaScript promises, but with a syntax that is idiomatic R.

Installation

Install the latest version of r-promises as follows:

guix install r-promises

Or install a particular version:

guix install r-promises@1.3.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of r-promises about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/r-promises'><img src='https://packages.guix.gnu.org/packages/r-promises/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/r-promises/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/r-promises)

Example Org:

[[https://packages.guix.gnu.org/packages/r-promises][https://packages.guix.gnu.org/packages/r-promises/badges/latest-version.svg]]