This package browser is in early development. Mind the rough edges.

r-promises 1.3.0

Abstractions for promise-based asynchronous programming

This package provides fundamental abstractions for doing asynchronous programming in R using promises. Asynchronous programming is useful for allowing a single R process to orchestrate multiple tasks in the background while also attending to something else. Semantics are similar to JavaScript promises, but with a syntax that is idiomatic R.

Installation

Install r-promises 1.3.0 as follows:

guix install r-promises@1.3.0

Or install the latest version:

guix install r-promises

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.