This package browser is in early development. Mind the rough edges.

ruby-character-set

Ruby library to manipulate Unicode

CharacterSet is a C-extended Ruby library to work with sets of Unicode code points. It can read and write these sets in various formats and implements the stdlib Set interface for them. It also offers an alternate paradigm of String processing which grants much better performance than Regexp and String methods from the stdlib where applicable. Many parts can be used independently, e.g.:

  • CharacterSet::Character

  • CharacterSet::Parser

  • CharacterSet::Writer

  • RangeCompressor

Installation

Install the latest version of ruby-character-set as follows:

guix install ruby-character-set

Or install a particular version:

guix install ruby-character-set@1.4.0

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.