rust-base16ct
Rust implementation of Base16 a.k.a hexadecimal
This package provides a pure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best effort" constant-time operation and embedded-friendly no_std support.
- Versions: 0.2.0 · 0.1.1
- Website: https://github.com/RustCrypto/formats/tree/master/base16ct
- Licenses: ASL 2.0 · Expat
- Package source: gnu/packages/crates-crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of rust-base16ct
as follows:
guix install rust-base16ct
Or install a particular version:
guix install rust-base16ct@0.1.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of rust-base16ct about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/rust-base16ct'><img src='https://packages.guix.gnu.org/packages/rust-base16ct/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/rust-base16ct/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/rust-base16ct)
Example Org:
[[https://packages.guix.gnu.org/packages/rust-base16ct][https://packages.guix.gnu.org/packages/rust-base16ct/badges/latest-version.svg]]