rust-base16ct 0.1.1
Rust implementation of Base16 a.k.a hexadecimal
This package provides a pure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best effort" constant-time operation and embedded-friendly no_std support.
- Website: https://github.com/RustCrypto/formats/tree/master/base16ct
- Licenses: ASL 2.0 · Expat
- Package source: gnu/packages/crates-crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install rust-base16ct 0.1.1
as follows:
guix install rust-base16ct@0.1.1
Or install the latest version:
guix install rust-base16ct
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.