This package browser is in early development. Mind the rough edges.

rust-libc

Raw FFI bindings to platform libraries like libc

The rust libc crate provides all of the definitions necessary to easily interoperate with C code (or "C-like" code) on each of the platforms that Rust supports. This includes type definitions (e.g., c_int), constants (e.g., EINVAL) as well as function headers (e.g., malloc).

This crate exports all underlying platform types, functions, and constants under the crate root, so all items are accessible as libc::foo. The types and values of all the exported APIs match the platform that libc is compiled for.

Installation

Install the latest version of rust-libc as follows:

guix install rust-libc

Or install a particular version:

guix install rust-libc@0.2.169

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of rust-libc about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/rust-libc'><img src='https://packages.guix.gnu.org/packages/rust-libc/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/rust-libc/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/rust-libc)

Example Org:

[[https://packages.guix.gnu.org/packages/rust-libc][https://packages.guix.gnu.org/packages/rust-libc/badges/latest-version.svg]]