rust-libc 0.2.169
Raw FFI bindings to platform libraries like libc
The rust libc crate provides all of the definitions necessary to easily interoperate with C code (or "C-like" code) on each of the platforms that Rust supports. This includes type definitions (e.g., c_int), constants (e.g., EINVAL) as well as function headers (e.g., malloc).
This crate exports all underlying platform types, functions, and constants under the crate root, so all items are accessible as libc::foo. The types and values of all the exported APIs match the platform that libc is compiled for.
- Outputs:
out
- Website: https://github.com/rust-lang/libc
- Licenses: ASL 2.0 · Expat
- Package source: gnu/packages/crates-io.scm
- Builds: See build status
- Issues: See known issues
Installation
Install rust-libc 0.2.169
as follows:
guix install rust-libc@0.2.169
Or install the latest version:
guix install rust-libc
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.