This package browser is in early development. Mind the rough edges.

rust-regex

Regular expressions for Rust

This package is an implementation of regular expressions for Rust. It uses finite automata and guarantees linear time matching on all inputs.

Installation

Install the latest version of rust-regex as follows:

guix install rust-regex

Or install a particular version:

guix install rust-regex@0.1.80

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.