rust-sec1
Rust implementation of SEC1: Elliptic Curve Cryptography encoding formats
This package provides a pure Rust implementation of SEC1: Elliptic Curve Cryptography encoding formats including ASN.1 DER-serialized private keys as well as the Elliptic-Curve-Point-to-Octet-String encoding.
- Versions: 0.7.3
- Website: https://github.com/RustCrypto/formats/tree/master/sec1
- Licenses: ASL 2.0 · Expat
- Package source: gnu/packages/crates-crypto.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of rust-sec1
as follows:
guix install rust-sec1
Or install a particular version:
guix install rust-sec1@0.7.3
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of rust-sec1 about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/rust-sec1'><img src='https://packages.guix.gnu.org/packages/rust-sec1/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/rust-sec1)
Example Org:
[[https://packages.guix.gnu.org/packages/rust-sec1][https://packages.guix.gnu.org/packages/rust-sec1/badges/latest-version.svg]]