rust-test-case 1.2.3
Procedural macro attribute for parametrized test cases
This crate provides #[test_case]
procedural macro attribute that generates multiple parametrized tests using one body with different input parameters. A test is generated for each data set passed in test_case attribute. Under the hood, all test cases that share same body are grouped into mod, giving clear and readable test results.
- Outputs:
out
- Website: https://github.com/frondeus/test-case
- Licenses: Expat
- Package source: gnu/packages/crates-io.scm
- Builds: See build status
- Issues: See known issues
Installation
Install rust-test-case 1.2.3
as follows:
guix install rust-test-case@1.2.3
Or install the latest version:
guix install rust-test-case
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.