rust-version-check 0.1.5
Check that the installed rustc meets some version requirements
This tiny crate checks that the running or installed rustc meets some version requirements. The version is queried by calling the Rust compiler with --version
. The path to the compiler is determined first via the RUSTC
environment variable. If it is not set, then rustc
is used. If that fails, no determination is made, and calls return None.
- Outputs:
out
- Website: https://github.com/SergioBenitez/version_check
- Licenses: ASL 2.0 · Expat
- Package source: gnu/packages/crates-io.scm
- Builds: See build status
- Issues: See known issues
Installation
Install rust-version-check 0.1.5
as follows:
guix install rust-version-check@0.1.5
Or install the latest version:
guix install rust-version-check
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.