sbcl-cl-xmlspam 0.0.0-1.ea06abc
Concise, regexp-like pattern matching on streaming XML for Common Lisp
CXML does an excellent job at parsing XML elements, but what do you do when you have a XML file that's larger than you want to fit in memory, and you want to extract some information from it? Writing code to deal with SAX events, or even using Klacks, quickly becomes tedious. cl-xmlspam
(for XML Stream PAttern Matcher) is designed to make it easy to write code that mirrors the structure of the XML that it's parsing. It also makes it easy to shift paradigms when necessary - the usual Lisp control constructs can be used interchangeably with pattern matching, and the full power of CXML is available when necessary.
- Website: https://github.com/rogpeppe/cl-xmlspam
- Licenses: Modified BSD
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install sbcl-cl-xmlspam 0.0.0-1.ea06abc
as follows:
guix install sbcl-cl-xmlspam@0.0.0-1.ea06abc
Or install the latest version:
guix install sbcl-cl-xmlspam
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.