sbcl-fxml 0.0.0-1.a0e73bb
XML parser and serializer in Common Lisp
FXML is a secure-by-default, error-recovering XML parser and serializer. It is a fork of CXML.
You should use FXML instead of CXML if:
You are parsing potentially ill-formed XML.
You are parsing potentially malicious XML.
You need to use Klacks with namespaces.
FXML’s API is very close to CXML's, and for the most part you can refer to the CXML documentation for usage.
- Website: https://github.com/ruricolist/fxml
- Licenses: LLGPL
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install sbcl-fxml 0.0.0-1.a0e73bb
as follows:
guix install sbcl-fxml@0.0.0-1.a0e73bb
Or install the latest version:
guix install sbcl-fxml
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.