This package browser is in early development. Mind the rough edges.

sbcl-jsown

Fast JSON reader / writer library for Common Lisp

jsown is a high performance Common Lisp JSON parser. Its aim is to allow for the fast parsing of JSON objects in Common Lisp. Recently, functions and macros have been added to ease the burden of writing and editing jsown objects.

jsown allows you to parse JSON objects quickly to a modifiable Lisp list and write them back. If you only need partial retrieval of objects, jsown allows you to select the keys which you would like to see parsed. jsown also has a JSON writer and some helper methods to alter the JSON objects themselves.

Installation

Install the latest version of sbcl-jsown as follows:

guix install sbcl-jsown

Or install a particular version:

guix install sbcl-jsown@1.0.1-1.744c440

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.