This package browser is in early development. Mind the rough edges.

sbcl-nactivitypub

Common Lisp implementation of ActivityPub and ActivityStreams standards

This package provides a Common Lisp implementation of ActivityPub and ActivityStreams standards for social networking.

Features:

  • Parsing and un-parsing ActivityStreams JSON-LD objects to/from CLOS objects with convenient accessors on those.

  • Sending and fetching ActivityStreams objects to/from the ActivityStreams-enabled HTTP(S) URLs.

  • Semantic info extraction with methods like name*, url*, author*, and published*.

  • No reliance on JSON parser. njson is used for parser-independent JSON handling. Load the parser backend you prefer!

Installation

Install the latest version of sbcl-nactivitypub as follows:

guix install sbcl-nactivitypub

Or install a particular version:

guix install sbcl-nactivitypub@0.0.5

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.

Badge code

You can use the following badge to inform users of sbcl-nactivitypub about the latest version available in Guix.

Example HTML:

<a href='https://packages.guix.gnu.org/packages/sbcl-nactivitypub'><img src='https://packages.guix.gnu.org/packages/sbcl-nactivitypub/badges/latest-version.svg' alt='Version in GNU Guix'></a>

Example Markdown:

[![Version in GNU Guix](https://packages.guix.gnu.org/packages/sbcl-nactivitypub/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/sbcl-nactivitypub)

Example Org:

[[https://packages.guix.gnu.org/packages/sbcl-nactivitypub][https://packages.guix.gnu.org/packages/sbcl-nactivitypub/badges/latest-version.svg]]