This package browser is in early development. Mind the rough edges.

sdsl-lite 2.1.1

Succinct data structure library

The Succinct Data Structure Library (SDSL) is a powerful and flexible C++11 library implementing succinct data structures. In total, the library contains the highlights of 40 research publications. Succinct data structures can represent an object (such as a bitvector or a tree) in space close to the information-theoretic lower bound of the object while supporting operations of the original object efficiently. The theoretical time complexity of an operation performed on the classical data structure and the equivalent succinct data structure are (most of the time) identical.

Installation

Install sdsl-lite 2.1.1 as follows:

guix install sdsl-lite@2.1.1

Or install the latest version:

guix install sdsl-lite

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.