uglify-js 0.1-1.429c5e1
JavaScript compressor
This is a Common Lisp version of UglifyJS, a JavaScript compressor. It works on data produced by parse-js
to generate a minified version of the code. Currently it can:
reduce variable names (usually to single letters)
join consecutive
var
statementsresolve simple binary expressions
group most consecutive statements using the
sequence
operator (comma)remove unnecessary blocks
convert
IF
expressions in various ways that result in smaller coderemove some unreachable code
- Outputs:
out
- Website: https://github.com/mishoo/cl-uglify-js
- Licenses: Zlib
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install uglify-js 0.1-1.429c5e1
as follows:
guix install uglify-js@0.1-1.429c5e1
Or install the latest version:
guix install uglify-js
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.