wabt 1.0.36
WebAssembly Binary Toolkit
WABT (pronounced: wabbit) is a suite of tools for WebAssembly, including:
wat2wasm
translates from WebAssembly text format to the WebAssembly binary formatwasm2wat
is the inverse; it translates from the binary format back to the text format (also known as a .wat)wasm-objdump
prints information about a wasm binary, similarly toobjdump
.wasm-interp
decodes ands run a WebAssembly binary file using a stack-based interpreterwat-desugar
parses .wat text form as supported by the spec interpreter (s-expressions, flat syntax, or mixed) and prints the canonical flat formatwasm2c
converts a WebAssembly binary file to a C source and header file.
These tools are intended for use in (or for development of) toolchains or other systems that want to manipulate WebAssembly files.
- Outputs:
out
- Website: https://github.com/WebAssembly/wabt
- Licenses: ASL 2.0
- Package source: gnu/packages/web.scm
- Builds: See build status
- Issues: See known issues
Installation
Install wabt 1.0.36
as follows:
guix install wabt@1.0.36
Or install the latest version:
guix install wabt
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.