This package browser is in early development. Mind the rough edges.

Packages

GNU Guix provides 21,817 packages transparently available as pre-built binaries. These pages provide a complete list of the packages. Our continuous integration system shows their current build status (updated June 4, 2023).

rust 1.67.1

Compiler for the Rust programming language

rust-rust-argon2 0.7.0

Argon2 password hashing function in Rust

rust-rust-argon2 0.8.3

Argon2 password hashing function in Rust

rust-rust-embed 5.9.0

Rust custom `Derive' macro

rust-rust-hawktracer 0.7.0

Rust bindings for hawktracer profiling library

rust-rust-ini 0.13.0

INI configuration file parsing library in Rust

rust-rust-ini 0.17.0

INI configuration file parsing library in Rust

rust-xxhash-rust 0.8.2

Implementation of xxHash in Rust

rust-yaml-rust 0.3.5

YAML 1.2 parser for Rust

rust-yaml-rust 0.4.5

YAML 1.2 parser for Rust

rust-jni 0.14.0

Rust bindings to the JNI

rust-jni 0.18.0

Rust bindings to the JNI

rust-jni 0.19.0

Rust bindings to the JNI

rust-analyzer 2022-01-10

Experimental Rust compiler front-end for IDEs

rust-pure-rust-locales 0.5.3

Pure Rust locales imported directly from the GNU C Library

rust-rust-embed-impl 5.9.0

Rust custom `Derive' macro

rust-rust-embed-utils 5.1.0

Utilities for `rust-embed'

rust-rust-hawktracer-sys 0.4.2

Sys crate for the rust_hawktracer library

rust-bencher 0.1.5

Port of the libtest benchmark runner to Rust stable

rust-json 0.11.15

JSON implementation in Rust

rust-lettre 0.9.6

Rust email client

rust-litrs 0.2.3

Parse and inspect Rust literals

rust-onig 6.1.1

Rust bindings for the Oniguruma regular expression library

rust-pyo3 0.13.2

Rust bindings for the Python interpreter

rust-pyo3 0.15.2

Rust bindings for the Python interpreter

rust-pyo3 0.16.5

Rust bindings for the Python interpreter

rust-schemars 0.8.8

Generate JSON Schemas from Rust code

rust-syn 0.11.11

Parser for Rust source code

rust-syn 0.13.11

Parser for Rust source code

rust-syn 0.14.9

Parser for Rust source code

rust-syn 0.15.44

Parser for Rust source code

rust-syn 1.0.109

Parser for Rust source code

rust-syn 2.0.5

Parser for Rust source code

rust-toml 0.2.1

Rust encoder and decoder of TOML-formatted files and streams

rust-toml 0.4.10

Rust encoder and decoder of TOML-formatted files and streams

rust-toml 0.5.11

Rust encoder and decoder of TOML-formatted files and streams

rust-toml 0.6.0

Rust encoder and decoder of TOML-formatted files and streams

rust-toml 0.7.3

Rust encoder and decoder of TOML-formatted files and streams

rust-tracing 0.1.36

Application-level tracing for Rust

rust-windows 0.32.0

Rust for Windows

rust-windows 0.46.0

Rust for Windows

rust-windows 0.9.1

Rust for Windows

rust-bio-types 0.12.1

Common biomedical types for use in rust-bio and rust-htslib

rust-sdl2-sys 0.35.2

Raw SDL2 bindings for Rust, used internally rust-sdl2

rust-rust-base58 0.0.4

Simple library for converting to and from base-58 strings

rust-rust-decimal 0.10.2

Decimal implementation suitable for financial calculations

rust-rust-decimal 1.14.3

Decimal implementation suitable for financial calculations

rust-rust-htslib 0.38.2

HTSlib bindings and API for reading and writing BAM files

i3status-rust 0.20.1

i3status, written in pure Rust

rust-actix 0.10.0

Actor framework for Rust

rust-actix 0.8.3

Actor framework for Rust

rust-addr2line 0.17.0

Symbolication library written in Rust, using gimli

rust-afl 0.8.0

Fuzzing Rust code with american-fuzzy-lop

rust-argmax 0.3.1

Rust library to deal with 'argument too long' errors

rust-arrow 4.4.0

Rust implementation of Apache Arrow

rust-arrow 5.2.0

Rust implementation of Apache Arrow

rust-arrow2 0.5.3

Unofficial implementation of Apache Arrow spec in safe Rust

rust-arrow2 0.7.0

Unofficial implementation of Apache Arrow spec in safe Rust

rust-askama 0.11.1

Type-safe, compiled Jinja-like templates for Rust

rust-atk 0.14.0

Rust bindings for the ATK library

rust-atk 0.8.0

Rust bindings for the ATK library

rust-autocfg 0.1.7

Automatic configuration for Rust compiler features

rust-autocfg 1.1.0

Automatic configuration for Rust compiler features

rust-backtrace 0.3.66

Acquire a stack trace (backtrace) at runtime in a Rust program

rust-barrel 0.6.5

Powerful schema migration building API for Rust

rust-bindgen 0.37.4

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.46.0

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.47.4

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.48.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.49.4

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.50.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.51.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.52.0

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.53.3

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.54.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.55.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.57.0

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.58.1

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.59.2

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.61.0

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.63.0

Generate Rust FFI bindings to C and C++ libraries

rust-bindgen 0.64.0

Generate Rust FFI bindings to C and C++ libraries

rust-bio 0.32.0

Bioinformatics library for Rust

rust-bio 0.33.0

Bioinformatics library for Rust

rust-bio 0.39.2

Bioinformatics library for Rust

rust-bio 0.41.0

Bioinformatics library for Rust

rust-bitmaps 2.1.0

Fixed size compact boolean array in Rust

rust-blake3 0.3.8

BLAKE3 hash function Rust implementation

rust-blake3 1.0.0

BLAKE3 hash function Rust implementation

rust-block 0.1.6

Rust interface for Apple's C language extension of blocks

rust-botan 0.8.1

Rust wrapper for Botan cryptography library

rust-boxfnonce 0.1.1

Safe FnOnce boxing for Rust

rust-brotli2 0.3.2

Rust bindings to compression library libbrotli

rust-bumpalo 3.7.0

Fast bump allocation arena for Rust

rust-caps 0.3.3

Pure-Rust library to work with Linux capabilities

rust-caps 0.5.2

Pure-Rust library to work with Linux capabilities

rust-cargo 0.68.0

Package manager for Rust

rust-cbindgen 0.12.2

Tool for generating C bindings to Rust code

rust-cbindgen 0.13.2

Tool for generating C bindings to Rust code

rust-cbindgen 0.14.1

Tool for generating C bindings to Rust code