This package browser is in early development. Mind the rough edges.

agda 2.6.4

Dependently typed functional programming language and proof assistant

Agda is a dependently typed functional programming language: it has inductive families, which are similar to Haskell's GADTs, but they can be indexed by values and not just types. It also has parameterised modules, mixfix operators, Unicode characters, and an interactive Emacs interface (the type checker can assist in the development of your code). Agda is also a proof assistant: it is an interactive system for writing and checking proofs. Agda is based on intuitionistic type theory, a foundational system for constructive mathematics developed by the Swedish logician Per Martin-Löf. It has many similarities with other proof assistants based on dependent types, such as Coq, Epigram and NuPRL.

Installation

Install agda 2.6.4 as follows:

guix install agda@2.6.4

Or install the latest version:

guix install agda

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.