cl-3d-quaternions
Quaternion and dual-quaternion functionality in Common Lisp
This is a library for quaternions. It contains most of the quaternion operations one would usually expect out of such a library and offers them both in non-modifying and modifying versions where applicable. It also tries to be efficient where plausible. Each quaternion is made up of float
s, which by default are single-float
s, as they do not require value boxing on most modern systems and compilers.
- Versions: 1.0.0-0.b79c15c
- Website: https://shinmera.github.io/3d-quaternions/
- Licenses: Zlib
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-3d-quaternions
as follows:
guix install cl-3d-quaternions
Or install a particular version:
guix install cl-3d-quaternions@1.0.0-0.b79c15c
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/cl-3d-quaternions/'><img src='http://127.0.0.1:3000/packages/cl-3d-quaternions/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/cl-3d-quaternions/badges/latest-version.svg)](http://127.0.0.1:3000/packages/cl-3d-quaternions/) Org: [[http://127.0.0.1:3000/packages/cl-3d-quaternions/][http://127.0.0.1:3000/packages/cl-3d-quaternions/badges/latest-version.svg]]