cl-data-structures
Data Structures and streaming algorithms for Common Lisp
CL-DATA-STRUCTURES is a Common Lisp library providing a portable collection of mutable and immutable data structures (dictionaries, sets, queues, sequences) and algorithms.
- Versions: 1.4.1-2.ffab568
- Website: https://sirherrbatka.github.io/cl-data-structures/main.html
- Licenses: FreeBSD
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-data-structures
as follows:
guix install cl-data-structures
Or install a particular version:
guix install cl-data-structures@1.4.1-2.ffab568
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of cl-data-structures about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/cl-data-structures'><img src='https://packages.guix.gnu.org/packages/cl-data-structures/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/cl-data-structures)
Example Org:
[[https://packages.guix.gnu.org/packages/cl-data-structures][https://packages.guix.gnu.org/packages/cl-data-structures/badges/latest-version.svg]]