cl-fast-ecs
Blazingly fast Entity-Component-System microframework
CL-FAST-ECS is a Common Lisp library providing an implementation of the ECS pattern, primarily focused on speed and interactive development.
ECS is an architectural data-oriented design pattern that allows for the effective processing of a large number of in-game objects while keeping the code and data separated. This provides flexibility in the way that game objects are built at runtime.
- Versions: 0.2.2
- Website: https://lockie.gitlab.io/cl-fast-ecs/
- Licenses: Expat
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-fast-ecs
as follows:
guix install cl-fast-ecs
Or install a particular version:
guix install cl-fast-ecs@0.2.2
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
HTML: <a href='http://127.0.0.1:3000/packages/cl-fast-ecs/'><img src='http://127.0.0.1:3000/packages/cl-fast-ecs/badges/latest-version.svg'></img></a> Markdown: [![GNU Guix](http://127.0.0.1:3000/packages/cl-fast-ecs/badges/latest-version.svg)](http://127.0.0.1:3000/packages/cl-fast-ecs/) Org: [[http://127.0.0.1:3000/packages/cl-fast-ecs/][http://127.0.0.1:3000/packages/cl-fast-ecs/badges/latest-version.svg]]