This package browser is in early development. Mind the rough edges.

cl-fast-ecs

Blazingly fast Entity-Component-System microframework

CL-FAST-ECS is a Common Lisp library providing an implementation of the ECS pattern, primarily focused on speed and interactive development.

ECS is an architectural data-oriented design pattern that allows for the effective processing of a large number of in-game objects while keeping the code and data separated. This provides flexibility in the way that game objects are built at runtime.

Installation

Install the latest version of cl-fast-ecs as follows:

guix install cl-fast-ecs

Or install a particular version:

guix install cl-fast-ecs@0.2.2

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.