cl-maxpc
Library for writing parsers and lexers based on combinatory parsing
Max’s Parser Combinators is a simple and pragmatic library for writing parsers and lexers based on combinatory parsing. MaxPC is capable of parsing deterministic, context-free languages, provides powerful tools for parse tree transformation and error handling, and can operate on sequences and streams. It supports unlimited backtracking, but does not implement Packrat Parsing. Instead, MaxPC achieves good performance through its optimized primitives, and explicit separation of matching and capturing input. In practice, MaxPC parsers perform better on typical computer languages—when compared to Packrat parsers—at the expense of not producing linear-time parsers.
- Versions: 0.0.0-1.e5e58d0
- Website: https://mr.gy/software/maxpc/api.html
- Licenses: AGPL 3
- Package source: gnu/packages/lisp-xyz.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of cl-maxpc
as follows:
guix install cl-maxpc
Or install a particular version:
guix install cl-maxpc@0.0.0-1.e5e58d0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of cl-maxpc about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/cl-maxpc'><img src='https://packages.guix.gnu.org/packages/cl-maxpc/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/cl-maxpc)
Example Org:
[[https://packages.guix.gnu.org/packages/cl-maxpc][https://packages.guix.gnu.org/packages/cl-maxpc/badges/latest-version.svg]]