clang
C language family frontend for LLVM
Clang is a compiler front end for the C, C++, Objective-C and Objective-C++ programming languages. It uses LLVM as its back end. The Clang project includes the Clang front end, the Clang static analyzer, and several code analysis tools.
- Versions: 9.0.1 · 8.0.1 · 7.1.0 · 6.0.1 · 3.9.1 · 3.8.1 · 3.7.1 · 3.5.2 · 19.1.7 · 18.1.8 · 17.0.6 · 16.0.6 · 15.0.7 · 14.0.6 · 13.0.1 · 12.0.1 · 11.1.0 · 10.0.1
- Website: https://clang.llvm.org
- Licenses: ASL 2.0
- Package source: gnu/packages/llvm.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of clang
as follows:
guix install clang
Or install a particular version:
guix install clang@10.0.1
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of clang about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/clang'><img src='https://packages.guix.gnu.org/packages/clang/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/clang/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/clang)
Example Org:
[[https://packages.guix.gnu.org/packages/clang][https://packages.guix.gnu.org/packages/clang/badges/latest-version.svg]]