clojure
Lisp dialect running on the JVM
Clojure is a dynamic, general-purpose programming language, combining the approachability and interactive development of a scripting language with an efficient and robust infrastructure for multithreaded programming. Clojure is a compiled language, yet remains completely dynamic – every feature supported by Clojure is supported at runtime. Clojure provides easy access to the Java frameworks, with optional type hints and type inference, to ensure that calls to Java can avoid reflection.
Clojure is a dialect of Lisp, and shares with Lisp the code-as-data philosophy and a powerful macro system. Clojure is predominantly a functional programming language, and features a rich set of immutable, persistent data structures. When mutable state is needed, Clojure offers a software transactional memory system and reactive Agent system that ensure clean, correct, multithreaded designs.
- Versions: 1.12.0
- Website: https://clojure.org/
- Licenses: ASL 2.0 · CPL 1.0 · EPL 1.0 · Modified BSD
- Package source: gnu/packages/clojure.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of clojure
as follows:
guix install clojure
Or install a particular version:
guix install clojure@1.12.0
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of clojure about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/clojure'><img src='https://packages.guix.gnu.org/packages/clojure/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[](https://packages.guix.gnu.org/packages/clojure)
Example Org:
[[https://packages.guix.gnu.org/packages/clojure][https://packages.guix.gnu.org/packages/clojure/badges/latest-version.svg]]