corosync
Group communication system for implementing High Availability in applications
The Corosync Cluster Engine is a Group Communication System with additional features for implementing high availability within applications. The project provides four C Application Programming Interface features:
A closed process group communication model with extended virtual synchrony guarantees for creating replicated state machines.
A simple availability manager that restarts the application process when it has failed.
A configuration and statistics in-memory database that provide the ability to set, retrieve, and receive change notifications of information.
A quorum system that notifies applications when quorum is achieved or lost.
- Versions: 3.1.6
- Website: https://corosync.github.io/corosync/
- Licenses: GPL 3+ · Zero-Clause BSD
- Package source: gnu/packages/high-availability.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of corosync
as follows:
guix install corosync
Or install a particular version:
guix install corosync@3.1.6
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.