This package browser is in early development. Mind the rough edges.

cppcheck

Static C/C++ code analyzer

Cppcheck is a static code analyzer for C and C++. Unlike C/C++ compilers and many other analysis tools it does not detect syntax errors in the code. Cppcheck primarily detects the types of bugs that the compilers normally do not detect. The goal is to detect only real errors in the code (i.e. have zero false positives).

Installation

Install the latest version of cppcheck as follows:

guix install cppcheck

Or install a particular version:

guix install cppcheck@2.10.3

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.