This package browser is in early development. Mind the rough edges.

discregrid 0.0.0-0.4c27e1c

Discretize functions on regular grids

Discregrid is a C++ library for the parallel discretization of (preferably smooth) functions on regular grids. It generates a (cubic) polynomial discretization given a box-shaped domain, a grid resolution, and a 3D scalar field. The library can also serialize and deserialize the generated discrete grid, and compute and discretize the signed distance field corresponding to a triangle mesh. The following programs are included with Discregrid:

  • GenerateSDF: Computes a discrete (cubic) signed distance field from a triangle mesh in OBJ format.

  • DiscreteFieldToBitmap: Generates an image in bitmap format of a two-dimensional slice of a previously computed discretization.

  • GenerateDensityMap: Generates a density map from a previously generated discrete signed distance field using the cubic spline kernel.

Installation

Install discregrid 0.0.0-0.4c27e1c as follows:

guix install discregrid@0.0.0-0.4c27e1c

Or install the latest version:

guix install discregrid

You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell documentation for more information.