ecl-lift
LIsp Framework for Testing
The LIsp Framework for Testing (LIFT) is a unit and system test tool for LISP. Though inspired by SUnit and JUnit, it's built with Lisp in mind. In LIFT, testcases are organized into hierarchical testsuites each of which can have its own fixture. When run, a testcase can succeed, fail, or error. LIFT supports randomized testing, benchmarking, profiling, and reporting.
- Versions: 1.7.1-3.a794184
- Website: https://github.com/gwkkwg/lift
- Licenses: Expat
- Package source: gnu/packages/lisp-check.scm
- Builds: See build status
- Issues: See known issues
Installation
Install the latest version of ecl-lift
as follows:
guix install ecl-lift
Or install a particular version:
guix install ecl-lift@1.7.1-3.a794184
You can also install packages in augmented, pure or containerized environments for development or simply to try them out without polluting your user profile. See the guix shell
documentation for more information.
Badge code
You can use the following badge to inform users of ecl-lift about the latest version available in Guix.
Example HTML:
<a href='https://packages.guix.gnu.org/packages/ecl-lift'><img src='https://packages.guix.gnu.org/packages/ecl-lift/badges/latest-version.svg' alt='Version in GNU Guix'></a>
Example Markdown:
[![Version in GNU Guix](https://packages.guix.gnu.org/packages/ecl-lift/badges/latest-version.svg)](https://packages.guix.gnu.org/packages/ecl-lift)
Example Org:
[[https://packages.guix.gnu.org/packages/ecl-lift][https://packages.guix.gnu.org/packages/ecl-lift/badges/latest-version.svg]]